Advertisement

HindustanTimes Thu,21 Aug 2014

World

Heartbleed: Freshly-discovered flaw compromises millions of online passwords
Agencies
San Francisco, April 09, 2014
First Published: 21:09 IST(9/4/2014)
Last Updated: 21:26 IST(9/4/2014)

Trust in the Internet took a major blow as alarm spread that software commonly used to encrypt and secure online transactions could wind up giving away the store.

Computer security specialists, website masters, and fans of online privacy were worriedly abuzz with word of a freshly-discovered flaw in online data-scrambling software that hackers can turn to their advantage.

A bug dubbed "Heartbleed" in OpenSSL encryption software lets attackers illicitly retrieve passwords and other bits of information from working memory on computer servers, according to cyber-defense specialists at Fox-IT.

Security experts have strongly advised people to change passwords, but wait a day or so before doing it. Reuters quoted Mark Seiden, an independent computer security consultant: "Immediately changing passwords could feed a new password into a website that has not fixed the flaw."

For websites, the fix-it process involves installing software patches on the computers in their data centers, then swapping out the confidential software key used to secure messages and transactions.

"Expect everybody who runs an https web server to be scrambling today," the Tor Project said in a warning posted at its website.

"If you need strong anonymity or privacy on the Internet, you might want to stay away from the Internet entirely for the next few days while things settle," it said.

OpenSSL is used to protect passwords, credit card numbers and other data coursing through the Internet.

Information considered at risk includes source codes, passwords, and "keys" that could be used to impersonate websites or unlock encrypted data.

"These are the crown jewels, the encryption keys themselves," said a heartbleed.com website devoted to details of the vulnerability.

"Leaked secret keys allows the attacker to decrypt any past and future traffic to the protected services and to impersonate the service at will."

The flaw in OpenSSL essentially allows a hacker to read the memory of a machine working the software, but no more than 64 kilobytes of data at a time, according to security specialists.

Nor can hackers control which bits of memory are tapped, leaving to chance what they get their hands on.

However, hackers could repeatedly grab packets of memory to ramp up the odds of stealing valuable data.

"There is no limit on the number of attacks that can be performed," Fox-IT said in a blog post that listed steps business IT handlers can take to thwart incursions.

Security researchers reported being able to dig out Yahoo password information by taking advantage of the bug. Yahoo released a statement Tuesday saying it had fixed the problem at its main online properties.

Fox-IT estimated that the vulnerability has existed for about two years, since the version of OpenSSL at issue was released.

OpenSSL is used by more than half of websites, but not all versions have the vulnerability, according to heartbleed.com.

The group behind open-source OpenSSL put out a security alert urging users to upgrade to an improved version of the software and gave credit for finding the bug to Neel Mehta of Google Security.

While it is not yet known whether hackers have exploited Heartbleed, operators of websites that used vulnerable version of OpenSSL need to switch to secure versions.

By late Tuesday, software patches and updates were being rushed out.

Websites will also need to change credentials used to verify authenticity in order to prevent hackers who may have looted the data from impersonating legitimate online venues and tricking visitors to enter valuable personal information.

As an added precaution, Internet users were advised to change passwords to online accounts or services they are intent on protecting.

OpenSSL shot to one of the hottest topics at Twitter.

"Shaking my head over recommendation to change passwords everywhere due to Heartbleed," Twitter @agentK said in message.

"If the service hasn't fixed OpenSSL, hardly worth it."

(With AFP and Reuters inputs)


Advertisement
Copyright © 2014 HT Media Limited. All Rights Reserved